Excel guide til HVIS-formlen

Excel er meget mere end blot en lommeregner. I excel er der nemlig over 300 forskellige formler du kan benytte dig af. Nogen af dem er selvfølgelig mere kendte end andre, og jeg vil med dette give en forklaring på en af de mest brugte formler:

HVIS-formlens egenskaber

En formel der kan være meget brugbar er HVIS-formlen. Den kan nemlig sortere tal så de udregnes på forskellige måder, alt efter hvilke kriterier der er.

Et kriterie kan fx være at en celle skal være større end 10.

Hvordan er HVIS-formlen opbygget?

Formlen er opbygget på denne måde:

=HVIS(LOGISK TEST;VÆRDI HVIS SAND;VÆRDI HVIS FALSK)

Jeg vil nu give en kort forklaring på hvad de forskellige ting betyder:

Logisk test:

Logisk test er den der afgør om værdien er sand eller falsk. Den logiske test kan laves på mange måder. Hvis det fx er en ligning, kan den logiske test skrives på følgende måde

C1=1

Ligningen behøver dog ikke nødvendigvis at være med tal, men kan fx også være med bogstaver:

C1=”JA”

Citationstegnene skal angives hvis der er tale om tekst. De kan også bruges ved tomme celler

C1=””

Dette kan være meget brugbart til hvis der ikke skal tages højde for tomme celler.

En logisk test kan også være i forhold til hvis et tal skal være større end et andet tal for at opnå kriteriet. Fx:

C1>10

Eller

C1<C2

Værdi hvis sand og værdi hvis falsk:

Her skrives hvad der skal gøres ved cellen, hvis den opfylder kriteriet. Her er der også et hav af muligheder.

Hvis vi laver et eksempel, kan vi sige at der er en uddannelse der kræver et karaktersnit på 10 for at kunne komme ind.

Dette ville kunne skrives på følgende måde:

=HVIS(C1>10;”optaget på uddannelsen”;”ikke optaget”)

Også her skal der bruges citationstegn, da der er tale om tekst.

Det kan også sorteres efter formler, frem for tekst.

Hvis der fx laves et simpelt eksempel med topskat.

Vi antager at der er topskat, hvis der skal tjenes over 40000kr. Topskatten er på 25%, mens den almindelige skat er på 20%. Her vil vores HVIS-formel se sådan ud i excel:

=HVIS(C2>40000;((C2-40000)*0,75+40000*0,8);C2*0,8)

Her antages det at det kun er den del over 40000kr der skal betales topskat af.

HVIS formel

Denne formel vil selvfølgelig kunne trækkes ned, så den gælder for alle rækker i et excel ark.

Hvis formel udviddet

Semikolon:

Der hvor det ofte går galt for folk der laver HVIS-formler, er at de glemmer at lave semikolon mellem hver oplysning. Der skal fx være semikolon mellem Logisk test; værdi hvis sand; og værdi hvis falsk.

Dette virker ikke umiddelbart så kompliceret, men det kan det nemt gå hen og blive, hvis der antages endnu flere scenarier.

Flere HVIS-formler i samme excel celle

Der er ingen grænser for hvor mange kriterier/betingelser der kan være i en formel.

Hvis vi bygger videre på vores eksempel med topskatten, kan det fx tilføjes at der ikke er den samme skat i alle lande. Det kan fx være at der i land nr. 2 er en topskat på 30%. Selvom der normalt kun er 2 udfald i en HVIS-formel er dette ikke en hindring, da der blot kan være flere i en:

Dette vil fx se sådan ud:

=HVIS(C2>40000;HVIS(B2=”land nr. 2”;((C2-40000)*0,7+40000*0,8);((C2-40000)*0,75+40000*0,8));C2*0,8)

Flere hvis formler

Det kan derfor ses at den eneste grænse der er for kriterier der kan tages med i en HVIS-formel, er ens egen evne til at holde tungen lige i munden. Tegnene i formlen skal nemlig placeres rigtigt. Jo mere omfattende formlen er, jo mere vanskelig bliver den at holde styr på.

Andre HVIS-funktioner

TÆL.HVIS-funktionen

Denne funktion kan bruges til at finde ud af hvor mange celler der opfylder et kriterie i et bestemt område af excel arket

Formlen er opbygget på denne måde:

=TÆL.HVIS(OMRÅDE;KRITERIER)

Område

Er de celler der skal tages med i regnearket. Hvis vi fx benytter vores eksempel fra før med topskat. Her vil vi fx kunne være interesserede i hvor mange der betalt topskat i vores eksempel. Området vi vil skulle bruge til at tjekke det vil derfor være fra C2 til C11. Dette skrives på følgende måde:

C1:C8

Kriterier

Kriterierne er dem der skal være opfyldt for at cellerne i excel arket bliver talt med.

I vores eksempel ville vi gerne finde ud af hvor mange der betalte topskat. Derfor vil vores kriterie være at der skal tjenes mere end 40000kr. Kriteriet vil derfor være >40000.

Vores formel vil derfor se sådan ud:

=TÆL.HVIS(C2:C11;”>40000”)

TÆL.HVIS

Denne funktion ville være rigtig god hvis der var rigtig mange tal i området, da den ville gøre det meget mere overskueligt.

About The Author

Related Posts